System requirements for all SpaceClaim products.

 

General Note:

One of the great things about SpaceClaim is that it doesn’t take a powerful computer to run the software. If your computer was built within the past 5 years or so then you’ll probably be able to use SpaceClaim. Believe it or not you can even run it on any Windows tablet!

Operating Systems:

  • Microsoft® Windows XP with Service Pack 3 1
  • Microsoft® Windows Vista™
  • Microsoft® Windows 7
  • Microsoft® Windows 8

SpaceClaim is not supported on virtual platforms (See note below).

Intel-based Apple hardware running native Windows using Boot Camp is not supported. (that being said we do have customers who run SpaceClaim in this environment without problems)

Video Card:

Requires Full DirectX® 9c, Shader Model 3.0 hardware support, 256 MB of graphics memory or higher, 32 bits per pixel, 1024×768 minimum resolution.
Please ensure that you have the latest graphics driver for your card and that Direct3D Acceleration is enabled.

The following commonly used video cards support the above requirements² :

Radeon®: ATI® Radeon R300, R420, R520, R600, or R700 series.
Radeon 9×00 cards (9700, 9800, …) or newer
NVIDIA®: NVIDIA GeForce® FX, 6, 7, or 8 series. NVIDIA FX5200s or newer
AMD™: AMD FireGL™ T2-128 or higher (including the ‘Mobility’ series for laptops)
CPU: Pentium® 4 2.0 GHZ or Athlon® 2000+ or faster, 32-bit (x86) or 64-bit (x64) processor

RAM:

Minimum: 512MB RAM (32-bit), 1Gb RAM (64-bit)
Recommended: 2GB RAM or higher

Other:

2 Button Mouse with Wheel
3D Mouse (3Dconnexion – Optional)

Multi-touch:

Multi-touch now works on all Windows 7 and 8 devices via the native pen-and-touch interface.

Note regarding Microsoft® .NET Framework 4.0:

SpaceClaim requires .NET 4.0, and an installer for .NET 4.0 is included within the SpaceClaim installer.
It is possible in some cases that a corrupt version of .NET will be detected as the correct version by the SpaceClaim installer. If this happens, SpaceClaim will be installed, but will not run properly. To remedy this, please manually install .NET 4.0 using Microsoft’s web site, Microsoft Update or Windows Update. On some occasions, this may involve cleaning the .NET installation by uninstalling any .NET components and re-installing them all. More details can be found on Microsoft’s web site here.

Once the .NET 4.0 installation is successful, the SpaceClaim installation should proceed normally.

Note on virtual platforms:

Users report successfully operating SpaceClaim on VMware Workstation 7.x and Player 3.x. ³
1. For the 64-bit version of Windows XP, Service Pack 2 is the latest and compatible with SpaceClaim.
2. SpaceClaim does not certify or recommend specific graphic cards.
3. SpaceClaim license is required for each emulated system running SpaceClaim

 Need Help?

If you have questions or concerns about your particular hardware configuration please send us an email (support@futurescape.ca) and we’ll do our best to help.